12 lines
641 B
Nix
12 lines
641 B
Nix
# DO NOT HAND-EDIT THIS FILE
|
|
let fetch = { private ? false, fetchSubmodules ? false, owner, repo, rev, sha256, ... }:
|
|
if !fetchSubmodules && !private then builtins.fetchTarball {
|
|
url = "https://github.com/${owner}/${repo}/archive/${rev}.tar.gz"; inherit sha256;
|
|
} else (import (builtins.fetchTarball {
|
|
url = "https://github.com/NixOS/nixpkgs/archive/3aad50c30c826430b0270fcf8264c8c41b005403.tar.gz";
|
|
sha256 = "0xwqsf08sywd23x0xvw4c4ghq0l28w2ki22h0bdn766i16z9q2gr";
|
|
}) {}).fetchFromGitHub {
|
|
inherit owner repo rev sha256 fetchSubmodules private;
|
|
};
|
|
json = builtins.fromJSON (builtins.readFile ./github.json);
|
|
in fetch json |